Completed
The scheduled maintenance has been completed.
Posted Jun 24, 2026 - 18:01 UTC
Verifying
The scheduled maintenance is now complete and the platform is operating normally. Any brief interruptions during the window have ended, and no action is required on your side. Thank you for your patience while we carried out this work.
Posted Jun 24, 2026 - 17:40 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 24, 2026 - 17:05 UTC
Scheduled
Our previously scheduled maintenance has now started. While the work is in progress, you may experience brief, intermittent interruptions when using parts of the platform. No action is required on your side, and services will resume automatically as the work completes. We will post a further update here once the maintenance is finished.
Posted Jun 24, 2026 - 17:05 UTC
This scheduled maintenance affected: Core services (Website, API, API Live Notification Service, Channels Synchronization, Reservation Processing, White Label, Guest Communication, Data Studio, Book Direct, Stripe Payment Processing), Sales Channel Integrations (Booking.com, Airbnb, Vrbo, Expedia, Google, TUI Villas, Homes & Villas by Marriott Bonvoy, Agoda, TripAdvisor, Other Sales Channel Integrations), and PMS integrations (Escapia, 365Villas, Guesty, Streamline, RNS Network, Turisoft, iPro, Hostfully, YesBookIt, Mews, TABS, Other PMS Integrations).